icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.kaibangdianzi.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

大发PK10 www.71728.cc-今天天天彩报纸| www.109584.com-派彩洗面奶-| www.202206.com-彩票中奖查询| www.296157.com-大发彩票合法吗| www.383396.com-怎样选彩票号码| www.570540.com-七彩云南翡翠手链| www.656991.com-七彩金龙-| www.775739.com-竞彩网强胆推荐| www.897299.com-彩票术语有那些| www.968429.com-英国快乐彩官网| www.yu25.com-美国彩票官网| www.35hg.cc-360彩票基本势图| www.0580.bid-福彩3d图迷第一版| www.8139.org-查看一下彩票开奖| www.38663.cc-彩易科思彩票app| www.91198.cc-好彩种类-| www.067590.com-建立彩票平台多少钱| www.149066.com-天天红彩票app| www.290585.com-江苏e球彩开奖结果| www.373301.com-伯乐彩票真假| www.518112.com-牛彩彩票官网| www.597751.com-福彩计划软件手机版| www.683001.com-高频彩票新政| www.774772.com-黄金8彩票网app| www.901746.com-体彩5d预测-| www.974727.com-彩票守号中一等奖| www.ae06.com-华人彩票首页| www.tz44.com-为什么足彩越玩越输| www.14vl.com-火箭彩票是什么意思| www.782.website凤凰微彩店-| www.5757.cc-环彩网安全吗| www.16557.cc-福彩四等奖结果| www.66959.com-彩票事业编制改革| www.076274.com-法国彩票-| www.151708.com-4个数字的彩票| www.261712.com-澳客网竞彩胜平负| www.360071.com-七星彩手机选号网| www.459618.com-济宁福利彩票游戏室| www.558828.com-彩虹照片唯美| www.637522.com-彩虹六号辅助提卡| www.770959.com-a彩娱乐app-| www.868537.com-七星彩割码规律图| www.954943.com-辽宁福彩双色球官网| 恒彩www.hcw778.com| www.ix71.com-河北了快三走势图| www.h33.com-财政部控制体育彩票| www.45yd.com-足球彩票漏洞| www.920.date-买彩票中奖秘籍| www.5998.cc-新浪彩票大乐透预测| www.18398.cc-福彩选号助手安全吗| www.66385.com-体育彩票竞彩店图片| www.096208.com-四川省体彩管理中心| www.172631.com-彩票大小单双骗局| www.279493.com-时时彩助手3| www.375713.com-体彩11选五任选2| www.505537.com-百姓彩票网投是多少| www.582034.com-彩店宝彩票是否合法| www.661719.com-旺彩可以买彩票| www.777667.cc-百度中彩彩票| www.873798.com-35彩票登录网址| www.951075.com-新华网彩票频道| 双赢彩票www.sytg9.com| www.eh50.com-福建体彩31-| www.wy47.com-万彩吧c8cn高手| www.20ea.com-2元彩票全中多少钱| www.0153.xyz-彩色的东西是什么| www.7136.pw-建盏蓝麒麟七彩光| www.24022.com-买彩票上瘾离婚| www.70022.cc-体彩篮球竞彩平台| www.059225.com-福彩快三计算软件| www.144156.com-微彩吧福利-| www.236307.com-360彩票走势图表| www.316068.com-体彩可以手机投注吗| www.392120.com-手机可以买彩票| www.539608.com-釉下彩餐具多少钱| www.627615.com-福彩36选7规则| www.701774.com-云南保山彩票店加盟| www.784208.com-彩票开奖查视频| www.864390.com-新彩吧手机彩票网| www.932208.com-七星彩三字现规则| www.987615.com-汇彩网官网下载安装| www.iw5.cc-彩票选号助手下载| www.qf78.com-好赢彩app-| www.06ib.com-qq买彩票怎么买| www.78ks.com-香港三色彩有限司| www.1930.wang-金亚洲彩票下载| www.7648.pw-体育彩票图标排版| www.26454.com-彩票三三下载| www.72191.cc-598彩票登录| www.138654.com-鸿彩平台下载| www.220455.com-立彩彩票官方网站| www.295612.com-查彩票中奖号码| www.366632.com-黑彩多大金额会判刑| www.463331.com-福彩3d走彩吧助手| www.553020.com-高手网天空彩票| www.675812.com-香港好彩高手论坛| www.756363.com-58彩是真的吗| www.877666.cc-境外彩票诈骗| www.965009.com-境外彩票网站制作| 500彩票网www.61655u.com| www.fn92.com-中国福利手机彩票网| www.xs40.com-收贵州快三开奖结果| www.19qi.com-五行大师预测彩票| www.890.hk-快三第一个人门户| www.5059.cn-北京体彩app下载| www.04456.cc-微彩骗局-| www.47918.com-甘肃体彩ll前三直| www.92191.cc-湖北快三彩票| www.053209.com-郑州彩票店转让信息| www.188691.com-彩票屠龙-| www.262090.com-福利彩票网站| www.357606.com-顶呱刮彩票技巧| www.444143.com-体彩3d中奖号今天| www.532709.com-福彩三d热议| www.634155.com-长沙七彩集团| www.719355.com-彩吧彩票官方下载| www.792040.com-福彩中心胡雅清| www.867895.com-信博彩票网官网| www.952994.com-彩票网下载-| www.03nr.com-中信彩票大厅| www.81zp.com-竞彩双平怎么选| www.1645.com-中国千亿彩票| www.8888.link-射阳县体育竞彩店| www.40086.cc-彩票通用邀请码| www.86797.com-七星彩精彩论坛| www.036027.com-快三如何才能赚钱| www.135913.com-竞彩胜平负预测| www.209443.com-福彩排列5开奖| www.278259.com-福彩3d四码复式| www.381598.com-泰安体育彩票| www.501795.com-易彩乐分分彩| www.568459.com-秒秒彩开奖原理| www.633438.com-十二生肖彩泥| www.699270.com-比较靠谱的竞彩平台| www.772979.com-韩国时时彩开奖网站| www.892313.com-福彩3d缩水器| www.957384.com-吉林快三彩票网| www.998797.com-大小单双彩票叫什么| www.kj7.com-快三有多少种玩法| www.oi02.com-福彩开奖查询双色球| www.2ay.com-买竞彩最后都是输| www.53mz.com-宏祥彩票-| www.692.cm-竞彩网是什么网| www.4143.vip-彩虹6号手机版| www.9190.wang-爱乐透彩票软件| www.69017.com-国际彩票骗局| www.024450.com-新加坡天天彩| www.092011.com-一分时时彩计划人工| www.151988.com-全民彩票电脑版下载| www.254143.com-风发彩票app下载| www.319500.com-快三怎么买容易中奖| www.383963.com-彩票真假怎么查| www.573272.com-饰彩的意思-| www.637109.com-彩虹六号透视挂| www.727039.com-乐彩网是不是骗人的| www.794224.com-3d经彩网-| www.863138.com-河南智慧彩-| www.928735.com-旺财彩票代理| www.972413.com-多肉彩铅画教程| www.rw17.com-牛彩票是什么| www.0ss.cc-大发快3彩乐网| www.46tk.com-武汉体彩设备转让| www.303.in-体彩有江苏快三吗| www.3096.biz-买不了世界杯彩票|